WSJT-X: Error Loading LotW Users Data

When startin WSJT-X v2.0, an error is shown saying: “Error Loading LotW Users Data”. Dit is due to Windows systems not hndling Intermediate CA’s correctly when retrieving the LotW user data file thats been served from a secured website.

The solution is simple.
  • Start WSJT-X and click on file -> Open log directory.
  • Than, manually download this file and place it in the WSJT-X log directory.
  • The SSL error should be gone now.
  • 5 comments

    Skip to comment form

      • Glyn on 28/02/2019 at 17:23
      • Reply

      Very many thanks for your help in fixing this bug. I wish they all went away as easy. “True Ham Spirit”, publishing this fix. Best 73 Glyn GW0ANA

        • Jose on 27/06/2020 at 00:19
        • Reply

        How do we get this file when it is updated?
        “FETCH” in WSJT-X is not functioning and shows an SSL error.
        Jose
        N4BAA

      • Bill on 04/03/2019 at 13:57
      • Reply

      Glyn, the error you cite is not due to Windows SSL certificate handling. WSJT-X does not use the Windows proprietary SLL handing, instead it uses the OpenSSL library and the error is usually due to the user having not installed the OpenSSL libraries as directed by the WSJT-X User Guide. Since WSJT-X v2.0.1 the application no longer tries to fetch a LoTW Users file from the ARRL on startup so this error will not happen unless the user elects WSJT-X to fetch the file.

      73

        • Bill on 04/03/2019 at 13:58
        • Reply

        Sorry, meant to address that to you Randy. Please change the name in the comment. 73

    Leave a Reply

    Your email address will not be published.